diff options
author | Wilhelm Schuster | 2024-02-01 09:43:54 +0100 |
---|---|---|
committer | Wilhelm Schuster | 2024-02-01 09:43:54 +0100 |
commit | a7a142e8bf7086a64055795492cf2ac94c0fcc00 (patch) | |
tree | ec5334cfe6030cd93a8f3b94086096bf77db4ad0 /PKGBUILD | |
parent | 34a644145cb906ad8d17bbab97cf726e0a00c8e1 (diff) | |
download | aur-a7a142e8bf7086a64055795492cf2ac94c0fcc00.tar.gz |
Update to 0.2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 10 |
1 files changed, 5 insertions, 5 deletions
@@ -2,25 +2,25 @@ pkgname='python-preprocess-cancellation' _name=${pkgname#python-} _name_source=${_name/-/_} -pkgver=0.2.0 +pkgver=0.2.1 pkgrel=1 pkgdesc="GCode processor to add klipper cancel-object markers" arch=(any) url="https://github.com/kageurufu/cancelobject-preprocessor" license=('GPL3') -makedepends=('python-setuptools') +makedepends=('python-build' 'python-installer' 'python-wheel') optdepends=('python-shapely') source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name_source-$pkgver.tar.gz") -sha256sums=('eb68494e35c0a1fe83716f2a14e12b3e1cdedf9458752be1cace00f944d90760') +sha256sums=('e2f1224e1ba1603bdfdbf6937caaf91082dc849e5122e80a5328aa999433ce79') build() { cd "${srcdir}/${_name_source}-${pkgver}" - python setup.py build + python -m build --wheel --no-isolation } package() { cd "${srcdir}/${_name_source}-${pkgver}" - python setup.py install --root="$pkgdir" --optimize=1 --skip-build + python -m installer --destdir="$pkgdir" dist/*.whl } |