summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-06 08:26:04 -0500
committerCarlos Aznarán Laos2023-05-06 08:26:04 -0500
commite6291e745fa045bd770b26af8ba20ef9aa28f3a6 (patch)
treef20191b58fb0ab7e5a20f8373f8a97cac60b20f9 /PKGBUILD
parentab39bf7bef9c1d9a1d19d35e1c1bebd8ac890e6c (diff)
downloadaur-e6291e745fa045bd770b26af8ba20ef9aa28f3a6.tar.gz
Python 3.11 rebuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 562835799e41..72491dbc90fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,24 @@
_base=proteus
pkgname=python-${_base}
pkgver=6.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Library to access Tryton server as a client"
arch=(any)
url="https://www.tryton.org"
license=(LGPL3)
depends=(python-defusedxml python-dateutil)
-makedepends=(python-setuptools)
+makedepends=(python-build python-installer python-setuptools python-wheel)
optdepends=('python-trytond: Trytond server')
source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
sha512sums=('46b47ecc564aad4b222aeb84321d0503e791ca7a3df14c7295d1ed9093ea94e881a22d376dcd2e0b8e07a3f1d338800616957139631b86292b6e897e4b959470')
build() {
cd ${_base}-${pkgver}
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}