summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Blakeney2019-05-21 09:35:58 +1000
committerMark Blakeney2019-05-21 09:39:14 +1000
commitc505ed649c91fbb224d52490e5bb8243bb75fa94 (patch)
treee36724374bec3734ab157b1db5a5eca4927fabec /PKGBUILD
parentfaa4f0c50e76cc7bba219f47fe02fe148311c654 (diff)
downloadaur-c505ed649c91fbb224d52490e5bb8243bb75fa94.tar.gz
Relative paths should be allowed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86f10baa2baf..fd3312afda83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Boris Momcilovic <boris.momcilovic@gmail.com>
# Contributor: Jaroslav Lichtblau <svetlemodry@archlinux.org>
# Contributor: Elis Hughes <elishughes@googlemail.com>
+# Contributor: Mark Blakeney at bullet-systems dot net
pkgname=python-pssh
pkgver=2.3.1
-pkgrel=9
+pkgrel=10
pkgdesc="Parallel versions of the openssh tools ssh, scp, rsync, nuke, slurp"
arch=('any')
url="http://code.google.com/p/parallel-ssh/"
@@ -16,12 +17,14 @@ source=(https://storage.googleapis.com/google-code-archive-downloads/v2/code.goo
Imports-are-absolute-by-default-in-Python3.patch
pssh-typeerror-str-does-not-support-the-buffer-interface.patch
pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch
- pssh-read-stdin-as-bytes-in-Python-3.patch)
+ pssh-read-stdin-as-bytes-in-Python-3.patch
+ Relative-paths-should-be-allowed.patch)
sha256sums=('539f8d8363b722712310f3296f189d1ae8c690898eca93627fc89a9cb311f6b4'
'12257c60e7db3d152f0b3307d0cd0263a95bddfc856aa570908a0491a1a03c56'
'6b4574810b09f4ca855b81a036643aa27613ea69e1cd92755b9b9f155985d332'
'40b01fd5c2aa59542a5d1bf65a41b861733f71305a9799c1d1ca6661f228a891'
- '47c1af738d4ba252e9f35c5633da91bae2a2919a7b6b2bf425ee1f090d61c7fe')
+ '47c1af738d4ba252e9f35c5633da91bae2a2919a7b6b2bf425ee1f090d61c7fe'
+ '3ba2ec624ac2aa3dbd832311ade97b65ab389b4b4aa55a4b672447809c7b463a')
prepare() {
cd "${srcdir}"/pssh-$pkgver
@@ -34,6 +37,8 @@ prepare() {
patch -Np0 -i ../pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch
# fix FS#5153
patch -Np1 -i ../pssh-read-stdin-as-bytes-in-Python-3.patch
+# fix to allow relative paths
+ patch -Np1 -i ../Relative-paths-should-be-allowed.patch
}
package() {