summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSam Whited2018-10-01 20:30:36 -0500
committerSam Whited2018-10-01 20:31:45 -0500
commit7844b74adea1e25ae12ef8fb9a2ddb0b26521af7 (patch)
tree545db228f18f75dd40636dc4ad265f62a8b9e280 /PKGBUILD
parentb436799e15b4c1497590565e80a2fe22e47df80f (diff)
downloadaur-7844b74adea1e25ae12ef8fb9a2ddb0b26521af7.tar.gz
Fix license, deps, arch, and misc cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bfca188234ea..2972f5a23a2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,27 @@
+# Maintainer: Sam Whited <sam@samwhited.com>
+
pkgname=python-psycopg2-binary
_pkgname=psycopg2-binary
pkgver=2.7.5
-pkgrel=1
-pkgdesc="Python-PostgreSQL Database Adapter"
+pkgrel=2
+pkgdesc='Python-PostgreSQL Database Adapter'
conflicts=('python-psycopg2')
-url=http://initd.org/psycopg/
-arch=('any')
-license=('LGPL', 'ZPL')
-depends=('python')
+url='http://initd.org/psycopg/'
+arch=('x86_64')
+license=(
+ 'LGPL3'
+ 'ZPL'
+)
+depends=(
+ 'postgresql-libs'
+ 'python'
+)
makedepends=('python-setuptools')
source=("https://pypi.python.org/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('c2ac7aa1a144d4e0e613ac7286dae85671e99fe7a1353954d4905629c36b811c')
package() {
- cd ${srcdir}/${_pkgname}-${pkgver}
- python setup.py install --root="${pkgdir}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}"
}