summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Vainomaa2016-07-22 17:41:43 +0300
committerMark Vainomaa2016-07-22 17:41:43 +0300
commitcb1eaba3e27d68fc2236a1f55d95cd9b9830fcda (patch)
treec8db885c85fd4e028fd0d8e388afe79832413529 /PKGBUILD
parent4df090bd27f1ef3e6aa02c031bea609b4aa7faaa (diff)
downloadaur-python-pulsar-git.tar.gz
Fix incompatibility with some build environments
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b920a05b6f2..2afa28137fbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,10 +19,15 @@ build() {
true
}
+prepare(){
+ cd "$pkgname"
+ # Build needs to be done here to make pkgver() working
+ python setup.py build >&2
+}
+
pkgver() {
cd "$pkgname"
- # Build needs to be done here to get right version
- python setup.py build >/dev/stderr
+ # No, git hackery didn't work here.
cat pulsar.egg-info/PKG-INFO |grep "^Version:" | awk '{print $2}'
}