summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Vainomaa2016-07-22 17:17:04 +0300
committerMark Vainomaa2016-07-22 17:17:04 +0300
commit4df090bd27f1ef3e6aa02c031bea609b4aa7faaa (patch)
tree138c7f05adf227e96ff91e543c388298cb35a9ce /PKGBUILD
parent5bfe007832ddf42a71d43decfc8dd2bd0598de2f (diff)
downloadaur-4df090bd27f1ef3e6aa02c031bea609b4aa7faaa.tar.gz
Fix pkgver function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3901ae0b66c9..1b920a05b6f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,14 +14,16 @@ replaces=("python-pulsar")
source=("python-pulsar-git::git+https://github.com/quantmind/pulsar.git")
md5sums=("SKIP")
-pkgver() {
- cd "$pkgname"
- cat pulsar.egg-info/PKG-INFO |grep "^Version:" | awk '{print $2}'
-}
build() {
+ true
+}
+
+pkgver() {
cd "$pkgname"
- python setup.py build
+ # Build needs to be done here to get right version
+ python setup.py build >/dev/stderr
+ cat pulsar.egg-info/PKG-INFO |grep "^Version:" | awk '{print $2}'
}
package() {