summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAchmad Fathoni2022-03-12 00:41:46 +0700
committerAchmad Fathoni2022-03-12 00:41:46 +0700
commitdc7058a0f393c43c26a6a2cc7c9ddb629e4ae3d5 (patch)
tree572b75dd2263de1f99509afa48465ce16a17383f /PKGBUILD
downloadaur-dc7058a0f393c43c26a6a2cc7c9ddb629e4ae3d5.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca6dd368d0e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Achmad Fathoni<fathoni.id(at)gmail.com>
+pkgname=python-pur
+_pkgname=${pkgname:7}
+pkgver=6.0.1
+pkgrel=1
+pkgdesc="Update packages in a requirements.txt file to latest versions."
+arch=('any')
+url="https://pypi.org/project/pur"
+license=('BSD license')
+makedepends=(python-build python-installer)
+depends=('python-click')
+source=(https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz)
+sha256sums=('b8f701f8ed0dd424e2fab694866e5cac3954b5fa8dc2c1cd02c12b1d3c7660d7')
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}