summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHideaki Takahashi2020-10-25 00:23:42 -0400
committerHideaki Takahashi2020-10-25 00:23:42 -0400
commit3c69ceda9b5b98f45833deb71fac872ff008d98c (patch)
tree5c4270797cc87ac35d9ba686f8dc8317d9e3ed66 /PKGBUILD
parentd47fb1ed41b714b465f849d7c76ddbe61588d819 (diff)
downloadaur-python-pushbullet.py.tar.gz
update to 0.12.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90ee71572952..f8c79eaa6a69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,28 @@
# Maintainer: Hideaki Takahashi <mymelo+aur@gmail.com>
-python=python
-
-_libname=pushbullet.py
-pkgname=python-$_libname
-pkgver=0.11.1
+pkgname=python-pushbullet.py
+_name=${pkgname#python-}
+pkgver=0.12.0
pkgrel=1
pkgdesc="A simple python client for pushbullet.com."
depends=('python-requests' 'python-magic' 'python-websocket-client')
makedepends=('python-setuptools')
arch=('any')
-source=(https://github.com/randomchars/${_libname}/archive/${pkgver}.tar.gz)
-sha256sums=('7b25734638d36f6788e2cededd5c0684ca16510e9acf9c536e929a162b1dc608')
+source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz)
+sha256sums=('917883e1af4a0c979ce46076b391e0243eb8fe0a81c086544bcfa10f53e5ae64')
-url="https://github.com/randomchars/pushbullet.py"
+url="https://github.com/rbrcsk/pushbullet.py"
license=("MIT")
build() {
- cd $srcdir/$_libname-$pkgver
+ cd $srcdir/$_name-$pkgver
- $python setup.py build || return 1
+ python setup.py build || return 1
}
package() {
- cd $srcdir/$_libname-$pkgver
+ cd $srcdir/$_name-$pkgver
- $python setup.py install --root=$pkgdir
+ python setup.py install --root=$pkgdir
install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}