summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSlithery2015-12-19 23:11:22 +0000
committerSlithery2015-12-19 23:11:22 +0000
commitaa66b0e8e9e01537f99c5f9b65471c35614f15fa (patch)
tree1e3df12158160876d37779169888547985175a41 /PKGBUILD
downloadaur-aa66b0e8e9e01537f99c5f9b65471c35614f15fa.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7e1d6950f4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Slithery <aur at slithery dot uk>
+pkgname=python-py3sensors-hg
+pkgver=r15.0cf96f4e2cfe
+pkgrel=1
+pkgdesc=('Python bindings for libsensors.so from the lm-sensors project')
+arch=('any')
+url=('https://bitbucket.org/gleb_zhulik/py3sensors')
+license=('GPL')
+depends=('python' 'lm_sensors')
+makedepends=('mercurial')
+provides=('python-py3sensors')
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+source=("$pkgname"::hg+"$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}