summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Sorg2023-10-14 11:35:46 +0200
committerSimon Sorg2023-10-14 11:35:46 +0200
commit81e0d138102a840d956f2a060a014e7485d01e7a (patch)
tree57f608730fc6b053f76a27ebbe258c8675a0fd8c /PKGBUILD
downloadaur-python-pyannote.database-git.tar.gz
Add pyannote database git version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89bc5c30363d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Simon Sorg <simon.sorg@student.hpi.de>
+_dirname=pyannote-database
+_pkgname=pyannote.database
+pkgname=python-$_pkgname-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=5.0.1.gbac3225
+pkgrel=1
+pkgdesc="Reproducible experimental protocols for multimedia (audio, video, text) database"
+arch=('any')
+url="https://github.com/pyannote/pyannote-database"
+license=('MIT')
+depends=(
+ 'python-pyannote.core-git'
+ 'python-yaml'
+ 'python-pandas'
+ 'python-typer'
+)
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel'
+ 'python-pytest'
+)
+
+provides=("$_pkgname")
+conflicts=(${provides[@]})
+source=("$_dirname"::"git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_dirname"
+ printf "%s" "$(git describe --tags | cut -d "-" -f 1,3 | sed 's/.*v//' | sed 's/-/./')"
+}
+
+build() {
+ cd "$srcdir/$_dirname"
+ python -m build --no-isolation --wheel
+}
+
+package() {
+ cd "$srcdir/$_dirname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}
+
+