summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2021-02-05 14:07:42 -0500
committerGuillaume Horel2021-02-05 14:07:42 -0500
commitaa121dad47bbfabfae74a07df514e1ec5b7a75e5 (patch)
tree8efc02ee6e5ebab4987d10fa4375c4dcf4a6fe11 /PKGBUILD
parent699c04cde0b71b3a65cbdbedaf8a2893e14d09b3 (diff)
downloadaur-python-pyarrow.tar.gz
bump to 3.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 43c06d78631b..00acaf60eb9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='python-pyarrow'
_pkgname='arrow-apache-arrow'
-pkgver=2.0.0
+pkgver=3.0.0
pkgrel=1
pkgdesc="A columnar in-memory analytics layer for big data."
arch=('x86_64')
@@ -14,7 +14,7 @@ optdepends=('python-fsspec')
makedepends=('cmake' 'cython' 'python-setuptools')
source=("https://github.com/apache/arrow/archive/apache-arrow-$pkgver.tar.gz"
"tensorflow-abi.patch")
-sha256sums=('ea299df9cf440cfc43393ce12ee6d9a4c9d0dfa9fde33c3bc9b70ec25520a844'
+sha256sums=('fc461c4f0a60e7470a7c58b28e9344aa8fb0be5cc982e9658970217e084c3a82'
'b6efa43faf51ea69a5e60ccbfc390caaab5c898025f08db79eda76de4bfbd09e')
prepare(){
@@ -43,6 +43,6 @@ check(){
cd "$_pkgname-$pkgver"
git clone https://github.com/apache/arrow-testing.git testing
cd python
- ARROW_TEST_DATA="$srcdir/arrow-apache-arrow-$pkgver/testing/data" PARQUET_HOME=/usr pytest pyarrow/tests
+ ARROW_TEST_DATA="$srcdir/arrow-apache-arrow-$pkgver/testing/data" PARQUET_HOME=/usr pytest pyarrow/tests --deselect=pyarrow/tests/test_memory.py::test_env_var
}
# vim:ts=2:sw=2:et: