summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnna Brünisholz2024-03-18 10:16:27 +0100
committerAnna Brünisholz2024-03-18 10:16:27 +0100
commiteb69ecabb4a3edd9ed9bd715f2802ab017b90356 (patch)
treeb321c5953d46eb7450fc09de0efce2d4044fd33c /PKGBUILD
downloadaur-eb69ecabb4a3edd9ed9bd715f2802ab017b90356.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e773809ef3e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Anna Brünisholz <anna.bruenisholz@gmail.com>
+
+_name=pyberny
+pkgname=python-${_name,,}
+pkgver=0.6.3
+pkgrel=1
+pkgdesc="Molecular/crystal structure optimizer"
+arch=('any')
+url="https://github.com/jhrmnn/pyberny"
+license=("MPL-2.0")
+depends=('python>=3.5'
+ python-numpy)
+makedepends=('python-installer' 'python-wheel')
+
+_whl="${_name//-/_}-$pkgver-py3-none-any.whl"
+
+source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/$_whl")
+sha256sums=('edb37aee86cc0f607b88b7f504dc6708a3eb167c6fc48a7d36bb9f92d0302a1d')
+
+noextract=("$_whl")
+package() {
+ _python_version="$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')"
+ python -m installer --destdir="$pkgdir" "$_whl"
+}