summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStar Brilliant2017-03-24 13:40:31 +0800
committerStar Brilliant2017-03-24 13:40:31 +0800
commit9f0fc190362013fef839035e91ac4e60dc73c965 (patch)
treeaa5f3ecfc8f20f0d0164e9d956a208c7d12f23ee /PKGBUILD
parent4f8f30265f2deebde7f9d167b56c38936bf32296 (diff)
downloadaur-9f0fc190362013fef839035e91ac4e60dc73c965.tar.gz
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7f8e7908ab0..9085a92e5c0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Star Brilliant <echo bTEzMjUzQGhvdG1haWwuY29tCg== | base64 -d>
pkgname=('python-pybrain')
-pkgver=0
+pkgver=0.3.1
pkgrel=1
pkgdesc='A modular Machine Learning Library for Python'
arch=('i686' 'x86_64')
@@ -9,21 +9,15 @@ url='http://pybrain.org/'
license=('BSD')
depends=('python' 'python-numpy' 'python-scipy')
makedepends=('python-setuptools' 'git')
-source=("git+https://github.com/pybrain/pybrain.git")
-sha512sums=('SKIP')
-
-pkgver() {
- cd pybrain
- git describe --always | sed 's|-|.|g'
-
-}
+source=("pybrain-$pkgver.zip::https://github.com/pybrain/pybrain/zipball/$pkgver")
+sha512sums=('eb495b361464226e0c5b167f2edfa4876fc7c81856fdbc1e3069787a453ea345dcf314fd5c09fd694dd9c6ebe5b1d619b48c650b33b86ed9c510ecf8c26d9db0')
build() {
- cd pybrain
+ cd pybrain-pybrain-*
python setup.py build
}
package() {
- cd pybrain
+ cd pybrain-pybrain-*
python setup.py install --root="${pkgdir}" --optimize=1
}