summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNathan Owens2020-04-28 23:46:35 -0500
committerNathan Owens2020-04-28 23:46:35 -0500
commitb1d4aff034a24cef41808a00d7ea397f06af27e1 (patch)
tree32b92a9cbb8291a33f66464fdbd04d750ff42349 /PKGBUILD
parent9f0fc190362013fef839035e91ac4e60dc73c965 (diff)
downloadaur-b1d4aff034a24cef41808a00d7ea397f06af27e1.tar.gz
Update to 0.3.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9085a92e5c0f..117d89aa291f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Contributor: Star Brilliant <echo bTEzMjUzQGhvdG1haWwuY29tCg== | base64 -d>
+# Maintainer: Nathan Owens <ndowens @ artixlinux.org>
pkgname=('python-pybrain')
-pkgver=0.3.1
+pkgver=0.3.3
pkgrel=1
pkgdesc='A modular Machine Learning Library for Python'
-arch=('i686' 'x86_64')
+arch=('any')
url='http://pybrain.org/'
license=('BSD')
depends=('python' 'python-numpy' 'python-scipy')
makedepends=('python-setuptools' 'git')
-source=("pybrain-$pkgver.zip::https://github.com/pybrain/pybrain/zipball/$pkgver")
-sha512sums=('eb495b361464226e0c5b167f2edfa4876fc7c81856fdbc1e3069787a453ea345dcf314fd5c09fd694dd9c6ebe5b1d619b48c650b33b86ed9c510ecf8c26d9db0')
+source=("git+https://github.com/pybrain/pybrain#tag=$pkgver")
+sha512sums=('SKIP')
build() {
- cd pybrain-pybrain-*
+ cd pybrain
python setup.py build
}
package() {
- cd pybrain-pybrain-*
+ cd pybrain
python setup.py install --root="${pkgdir}" --optimize=1
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}