summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-05-25 08:35:14 -0600
committerMark Wagie2022-05-25 08:35:14 -0600
commitb170d694a89ac26940dff52c56d81fb1d4e201f3 (patch)
tree6c0c31e69472c847ad0611a4344938f88649e043 /PKGBUILD
parent3b1278d374df99058a7c775571229087c111d56e (diff)
downloadaur-b170d694a89ac26940dff52c56d81fb1d4e201f3.tar.gz
12.1.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c5541e68af3..8aa69a0d41bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=python-pychromecast
_name=PyChromecast
-pkgver=12.1.2
+pkgver=12.1.3
pkgrel=1
pkgdesc='Library for Python 3 to communicate with the Google Chromecast'
arch=('any')
@@ -16,7 +16,7 @@ license=('MIT')
depends=('python-protobuf' 'python-zeroconf' 'python-casttube')
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('6be626e5ba2f6ffaefbc13ddced84e8b60a9ef1b012f71039fc0f7a0bcb4bda6')
+sha256sums=('edd67b6d23d5d064a56c97cd90ea661fa8ffd76720bf199b5a126c6869f81e01')
build() {
cd "$_name-$pkgver"
@@ -27,9 +27,5 @@ package() {
cd "$_name-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
- # Symlink license to proper directory
- local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
- install -d "$pkgdir/usr/share/licenses/$pkgname"
- ln -s "${pkgdir}${site_packages}/$_name-$pkgver.dist-info/LICENSE" \
- "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}