summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortaotieren2023-12-21 02:01:55 +0800
committertaotieren2023-12-21 02:01:55 +0800
commit59e58a8434abadde046d4e109df5dcd459e5458f (patch)
tree2158b44b70b3462c197b4056d387f910f40db439 /PKGBUILD
parent973db4a5a3fd7d1049e834456e5585549f3cf8e0 (diff)
downloadaur-python-pyclipper-git.tar.gz
[lilac] updated to 1.3.0.post5.r3.g410553d-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d9beb055fbb7..8b503daafb4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: taotieren <admin@taotieren.com>
pkgname=python-pyclipper-git
-pkgver=1.3.0.post4.r0.ge349e2b
+pkgver=1.3.0.post5.r3.g410553d
pkgrel=1
pkgdesc='Cython wrapper for the C++ translation of the Angus Johnsons Clipper library'
url='https://github.com/fonttools/pyclipper'
@@ -23,6 +23,11 @@ pkgver() {
git describe --long --tags | sed 's/^v//g;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare()
+{
+ git -C "${srcdir}/${pkgname}" clean -dfx
+}
+
build() {
cd "$pkgname"
python setup.py build_ext --inplace