summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Schlatow2015-06-20 17:57:06 +0200
committerJohannes Schlatow2015-06-20 17:57:06 +0200
commit23031d0b4fc6308b294a9cda61a0c6ddafeecbbf (patch)
tree0b8d5eaa37c386aedac0a9a5fcba203fbb635e56 /PKGBUILD
downloadaur-23031d0b4fc6308b294a9cda61a0c6ddafeecbbf.tar.gz
migrate to AUR4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5856ba78f229
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Johannes Schlatow <johannes.schlatow@googlemail.com>
+
+_pkgname=python-pycpa
+pkgname=$_pkgname-hg
+pkgver=20150317
+pkgrel=1
+pkgdesc="Pragmatic Python implementation of Compositional Performance Analysis (aka the SymTA/S approach provided by Symtavision) used for research in worst-case timing analysis."
+arch=('any')
+makedepends=('mercurial')
+depends=('python' 'python-matplotlib' 'python-pygraphviz' 'simpy' 'python-setuptools' 'python-nose' 'python-tornado')
+provides=('pycpa')
+url="https://bitbucket.org/pycpa/pycpa/"
+license=('MIT')
+
+source=("hg+https://bitbucket.org/pycpa/pycpa")
+md5sums=("SKIP")
+
+build() {
+ cd ${srcdir}/pycpa
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/pycpa
+ python setup.py install --root="${pkgdir}"
+}