summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOlivier Le Moal2020-01-04 17:02:01 +0100
committerOlivier Le Moal2020-01-04 17:02:01 +0100
commitef96b8bbf0c4b97422c82f70a96db3f8c05e241c (patch)
tree4eee037f628a81d81fdd83990cdb3e93cddba6a6 /PKGBUILD
parentb67ca4d4e8cabb9a0a35b97aede275fc9ed26c83 (diff)
downloadaur-ef96b8bbf0c4b97422c82f70a96db3f8c05e241c.tar.gz
Drop python2 support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 8 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 31d75a34ee05..c57de6eee08a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,20 @@
# Maintainer: Olivier Le Moal <mail@olivierlemoal.fr>
-pkgbase=python-pycrate
-pkgname=('python2-pycrate' 'python-pycrate')
+pkgname='python-pycrate'
pkgver=0.4
-pkgrel=2
+pkgrel=3
pkgdesc="Python library for manipulating various digital formats in an easy way."
arch=(any)
+conflicts=("python-pycrate-git")
+depends=('python')
+optdepends=('python-lxml: The pycrate_diameter part uses lxml as optional dependency to translate xml files from IANA as Python dictionnaries when the diameter module is loaded.'
+ 'python-sctp: The pycrate_corenet part requires pysctp to run.'
+ 'python-cryptomobile: The pycrate_corenet part requires CryptoMobile to run. The pycrate_mobile/TS24301_EMM and pycrate_mobile/TS24501_FGMM modules use CryptoMobile as optional dependency to cipher / decipher LTE and 5G NAS messages.')
url="https://github.com/P1sec/pycrate"
license=('LGPL2.1')
source=(https://github.com/P1sec/pycrate/archive/${pkgver}.tar.gz)
md5sums=('0a3a6747c3d87929bd50e3be349b2dea')
-package_python-pycrate() {
- depends=('python')
- conflicts=("python2-pycrate" "python-pycrate-git" "python2-pycrate-git")
-
+package() {
cd pycrate-${pkgver}
python setup.py install --root="$pkgdir" --optimize=1
}
-
-package_python2-pycrate() {
- depends=('python2')
- conflicts=("python-pycrate" "python-pycrate-git" "python2-pycrate-git")
-
- cd pycrate-${pkgver}
- python2 setup.py install --root="$pkgdir" --optimize=1
-}