summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcell Meszaros2022-07-10 21:34:42 +0200
committerMarcell Meszaros2022-07-10 21:38:50 +0200
commitcd3e5a690a93f49a982cb7239da39ffa2c2908ae (patch)
tree4f4aaba908719c61353722e29cf4ad07f06dfd84 /PKGBUILD
parent4b79c350e5406d6047667005523fb9dccb0fa287 (diff)
downloadaur-python-pycrypto.tar.gz
2.7a1-5: revert changes in pkgrel 3 and 4 (Python3 version range constraint)
Seems it its not such a straightforward matter to set a package to use earlier Python versions as I've originally thought. This reverts commit 4b79c350e5406d6047667005523fb9dccb0fa287. This reverts commit 469d226670916334c5e79d28ed91a6d4b390692f.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e195833d87f..39d3c3e2efc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,12 @@ pkgbase='python-pycrypto'
pkgname=('python-pycrypto' 'python-crypto')
_name="${pkgbase#python-}"
pkgver=2.7a1
-pkgrel=4
+pkgrel=5
pkgdesc='[DEPRECATED since 2013] Cryptographic primitives and algorithms for Python'
arch=('x86_64')
_repourl="https://github.com/${_name}/${_name}"
url="${_repourl}/blob/master/README.md"
license=('custom:Unlicense' 'PSF')
-depends=(
- 'python>=3.3'
- 'python<3.9')
makedepends=(
'gmp'
'python-setuptools'
@@ -39,11 +36,14 @@ build() {
package_python-pycrypto() {
arch=('any')
license=('Unlicense')
- depends+=("python-crypto=${pkgver}")
+ depends=("python-crypto=${pkgver}")
}
package_python-crypto() {
- depends+=('gmp')
+ depends=(
+ 'gmp'
+ 'python'
+ )
cd "${_tarname}"
python setup.py install --root="${pkgdir}" --prefix='/usr' --optimize=1 --skip-build