summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2022-11-05 20:33:51 +0800
committerlilac2022-11-05 20:33:51 +0800
commit44b24b12f1c9e994ad8e5cd544d436aaeab17688 (patch)
tree06d43a41218821960ae3dc896735703767c1f165 /PKGBUILD
parente705a04d5b7ea32892c81ed6ceceb41d68c1fdb0 (diff)
downloadaur-44b24b12f1c9e994ad8e5cd544d436aaeab17688.tar.gz
[lilac] updated to 0.8.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d07e944855d0..9241d6c79220 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=pydeck
pkgname=python-pydeck
-pkgver=0.7.1
-pkgrel=4
+pkgver=0.8.0
+pkgrel=1
pkgdesc='Widget for deck.gl maps'
arch=('any')
url='https://pypi.org/project/pydeck'
@@ -25,18 +25,11 @@ makedepends=(
source=("${_pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
)
-sha512sums=('7d4d392a11ae26a9efd138eac6286ed08055613b8aba10ea8888d3d862ef21af13d588ceb6058a5cedbff564fed17b9da5c19f7deeacd6030f0c7dd0ac9afaa3')
-
-prepare() {
- # fix version number
- sed -i "s,0.3.0,${pkgver}," "${_pkgname}-${pkgver}/pyproject.toml"
- # quick fix for building
- sed -i "4i [build-system]" "${_pkgname}-${pkgver}/pyproject.toml"
-}
+sha512sums=('117ba93c3338ab53b34afd9974b4b6408f4287d2f2db340ffa63a6bbe1ca6632939ea50dd5e81d04d76c69634b486a4d34a119eb3a3ad3fa7cb4087c87f8c932')
build() {
cd "${_pkgname}-${pkgver}"
- python -m build --wheel --no-isolation
+ python -m build --wheel --no-isolation -x
}
package() {