summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorvsilv2016-02-09 16:30:41 +0100
committervsilv2016-02-09 16:30:41 +0100
commita98d2931fbf45ad88bce33310a7a6b0dbc581143 (patch)
tree5055dd508c655041774f3bb92072770f64515bc0 /PKGBUILD
downloadaur-a98d2931fbf45ad88bce33310a7a6b0dbc581143.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a835dbf811c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: vsilv <vsilv@posteo.eu>
+# Maintainer : vsilv <vsilv@posteo.eu>
+pkgname=python-pydstool-git
+pkgver=v0.90.2
+pkgrel=1
+pkgdesc="PyDSTool is a sophisticated & integrated simulation and analysis environment for dynamical systems models of physical systems (ODEs, DAEs, maps, and hybrid systems)."
+arch=('i686' 'x86_64')
+url="https://github.com/robclewley/pydstool"
+license=('BSD')
+depends=('python>=3.3' 'python-numpy' 'python-scipy')
+makedepends=('git')
+provides=('python-pydstool')
+source=('pydstool::git+https://github.com/robclewley/pydstool.git')
+
+md5sums=('SKIP')
+_gitname='pydstool'
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+build() {
+ cd "${srcdir}/${_gitname}"
+ python setup.py install
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ python setup.py install --prefix=/usr --root=${pkgdir} -O1 --skip-build
+
+}
+