summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2021-08-21 16:38:03 +0300
committerCaleb Maclennan2021-08-21 16:38:03 +0300
commit30a13590ab41ee972ffb21754ac787abbbccc6a1 (patch)
tree8ef789dfb8ce0fda4ebe64584cdbce86b669bcf8 /PKGBUILD
parentf272412ca90283dc3cc5a46595d2cc0ecdc078de (diff)
downloadaur-30a13590ab41ee972ffb21754ac787abbbccc6a1.tar.gz
upgpkg: python-pydyf 0.1.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 18 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29210632407f..c93d9356d715 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,41 @@
_pyname=pydyf
pkgname=python-$_pyname
-pkgver=0.0.3
+pkgver=0.1.0
pkgrel=1
pkgdesc='a low-level PDF generator written in Python and based on PDF specification 1.7'
arch=(any)
-url="https://github.com/CourtBouillon/$_pyname"
+url="https://www.courtbouillon.org/$_pyname"
license=(BSD)
depends=(python
python-sphinx_rtd_theme)
makedepends=(python-setuptools
python-sphinx)
+checkdepends=(ghostscript
+ python-pillow
+ python-pytest)
_archive="$_pyname-$pkgver"
source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.tar.gz")
-sha256sums=('d12ad2ddce4c49c32a7fa06c4b9cf4166d6f4659b6314961a4dedb0857c2d246')
+sha256sums=('1764773ff01d71f941497d6dd32a21b87baf5b98f86cd47965ac33f3eb64c127')
+
+prepare() {
+ cd "$_archive"
+ # We don't want any of the special pytest options injected
+ sed -i -e '/^addopts/d' pyproject.toml
+}
build() {
cd "$_archive"
- export PYTHONHASHSEED=0
python setup.py build
}
+check() {
+ cd "$_archive"
+ pytest
+}
+
package() {
cd "$_archive"
+ export PYTHONHASHSEED=0
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}