summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM0Rf302019-11-07 19:47:25 +0100
committerM0Rf302019-11-07 19:47:25 +0100
commit3d9034054eca873825ee2fab2262a84b274de148 (patch)
tree555f9429cc91e331c694e57dd56e00ad6b6b5daa /PKGBUILD
parenta0e5bbed58d5d2e0a2503e29b4cb515fc81da130 (diff)
downloadaur-3d9034054eca873825ee2fab2262a84b274de148.tar.gz
python-pyelliptic: removed python2 references
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 7 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 031eef0267d7..ca41732de36a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,8 @@
# Maintainer: robertfoster
-pkgbase=python-pyelliptic
-pkgname=('python2-pyelliptic' 'python-pyelliptic')
-_pkgname=pyelliptic
+pkgname=python-pyelliptic
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Python OpenSSL wrapper for ECC (ECDSA, ECIES), AES, HMAC, Blowfish, ..."
arch=(any)
url="https://github.com/radfish/pyelliptic"
@@ -14,25 +12,13 @@ makedepends=('python-setuptools')
source=(https://github.com/radfish/pyelliptic/archive/$pkgver.tar.gz)
build() {
- cp -a ${_pkgname}-${pkgver}{,-py2}
-
- cd ${_pkgname}-${pkgver}
- python setup.py build
-
- cd ../${_pkgname}-${pkgver}-py2
- python2 setup.py build
-}
-
-package_python-pyelliptic(){
- provides=("$pkgname=$pkgver")
- cd ${_pkgname}-${pkgver}
- python setup.py install --root="$pkgdir" --skip-build
+ cd ${pkgname##python-}-${pkgver}
+ python setup.py build
}
-package_python2-pyelliptic(){
- provides=("$pkgname=$pkgver")
- cd ${_pkgname}-${pkgver}-py2
- python2 setup.py install --root="$pkgdir" --skip-build
+package() {
+ cd ${pkgname##python-}-${pkgver}
+ python setup.py install --root="$pkgdir" --skip-build
}
sha256sums=('840ad6f5e79c633e1de79fb08be78bf76fe07a7f260905eea31efb5ddf00180d')