summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFeakster2021-01-20 22:15:31 +0000
committerFeakster2021-01-20 22:15:31 +0000
commitf3b0920c903235c9a852865c532b891c2cd8b0d1 (patch)
treeffc2df71ee0cddc3e18b8be963a8b989bd648586 /PKGBUILD
downloadaur-f3b0920c903235c9a852865c532b891c2cd8b0d1.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc75520cab3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Feakster <feakster at posteo dot eu>
+
+### Notes ###
+# - Repo: 'https://github.com/physimals/pyfab'
+
+### Info ###
+pkgname=python-pyfab
+_pkgname=${pkgname/python-/}
+pkgver=0.3.5
+pkgrel=1
+pkgdesc='Python interface to the Fabber Bayesian model fitting tool'
+arch=('any')
+url='https://pyfab.readthedocs.io/en/latest/'
+license=('custom:PYFAB license')
+depends=('fsl>=6.0.1' 'fslpy' 'python' 'python-numpy' 'python-nibabel' 'python-six')
+makedepends=('git' 'python-setuptools' 'sed')
+options=(!emptydirs)
+source=("$pkgname::git+https://github.com/physimals/${_pkgname}.git#tag=v$pkgver")
+b2sums=('SKIP')
+
+### Build ###
+build() {
+ ## Change Directory ##
+ cd "$srcdir/$pkgname"
+
+ ## Build ##
+ python setup.py build
+}
+
+### Package ###
+package() {
+ ## Change Directory ##
+ cd "$srcdir/$pkgname"
+
+ ## Install Package ##
+ python setup.py install \
+ --prefix=/usr \
+ --root="$pkgdir"/ \
+ --optimize=1 \
+ --skip-build
+
+ ## Install License ##
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
+}