summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeonid Bloch2023-10-30 11:07:39 +0200
committerLeonid Bloch2023-10-30 11:07:39 +0200
commitd75097ebd53a0288b67b3d2d777cc848c09eac55 (patch)
tree0795120da75aefbebecfe3784114a1ac5910cfb8 /PKGBUILD
parenta9516aa0b656674e07fc10346c935fcd9cf6f7c4 (diff)
downloadaur-d75097ebd53a0288b67b3d2d777cc848c09eac55.tar.gz
Switch to the new build system
Signed-off-by: Leonid Bloch <lb.workbox@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 46ce6b1c1137..93cd255b374f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Upstream contact: silx at esrf dot fr
pkgname=python-pyfai
pkgver=2023.09
-pkgrel=1
+pkgrel=2
pkgdesc="Fast Azimuthal Integration in Python."
arch=('any')
url="http://www.silx.org"
@@ -10,18 +10,24 @@ license=('GPLv3' 'BSD' 'MIT')
depends=('python-numpy' 'python-scipy' 'python-matplotlib' 'python-fabio'
'python-h5py' 'python-pyopencl' 'python-pyqt5' 'fftw'
'opencl-driver')
-makedepends=('cython')
+makedepends=('cython' 'meson-python' 'python-build' 'python-installer'
+ 'python-wheel')
source=("https://github.com/silx-kit/pyFAI/archive/v${pkgver}.tar.gz")
sha256sums=('d6cdd92a165d2b2c098095a1ddf7424cd77aeb52a1c36e730c2bf792d8d65fec')
build() {
cd "pyFAI-${pkgver}"
- python setup.py build
+
+ # Remove ninja dependency, as it is brought with meson, and python-ninja
+ # is not in the official repos
+ sed -i "/^requires =/,/^\]/{/^[[:space:]]*'ninja',[[:space:]]*$/d}" pyproject.toml
+
+ python -m build --wheel --no-isolation
}
package() {
cd "pyFAI-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -D LICENSES.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D copyright "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
}