summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2020-03-03 18:54:48 +0100
committerFabioLolix2020-03-03 18:54:48 +0100
commitc86c8b63a607bf61feed5e4b8fcf93c19b12cb2e (patch)
tree752e9b44141b4a39c16c8a3c0a3ce8e74b55bdbf /PKGBUILD
downloadaur-c86c8b63a607bf61feed5e4b8fcf93c19b12cb2e.tar.gz
v1.9.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a9879e865dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Yunhui Fu <yhfudev at gmail dot com>
+# Contributor: Benjamin Chretien <chretien at lirmm dot fr>
+# Contributor: zarra <zarraxx@gmail.com>
+
+pkgname=python-pygccxml
+pkgver=1.9.1
+pkgrel=1
+pkgdesc="Simple framework to navigate C++ declarations, using Python classes."
+arch=(any)
+url="https://github.com/gccxml/pygccxml"
+license=(Boost)
+depends=(castxml python)
+makedepends=(python-setuptools)
+checkdepends=(python-pycodestyle)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/gccxml/pygccxml/archive/v${pkgver}.tar.gz")
+sha256sums=('2fb4e18f7a3ae039a05230ca58f11e1fc925c8643f926a1be481bb4338414a95')
+
+build() {
+ cd "${srcdir}/pygccxml-${pkgver}"
+ python setup.py build
+}
+
+check() {
+ cd "${srcdir}/pygccxml-${pkgver}"
+ python -m unittests.test_all
+}
+
+package() {
+ cd "${srcdir}/pygccxml-${pkgver}"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}