summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulien Nicoulaud2022-01-04 17:34:03 +0100
committerJulien Nicoulaud2022-01-04 17:34:03 +0100
commitec3b4312a5e12bc750cd48e0cd4917da7b8602f1 (patch)
tree0a691cade3606e029d8709dfa4c014895cae5d62 /PKGBUILD
downloadaur-python-pygitguardian.tar.gz
1.3.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc0a8456ebba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Julien Nicoulaud <julien.nicoulaud@gmail.com>
+_pkgname=pygitguardian
+pkgname=python-${_pkgname}
+pkgver=1.3.3
+pkgrel=1
+pkgdesc="GitGuardian API Client."
+arch=(any)
+url="https://github.com/GitGuardian/py-gitguardian"
+license=(MIT)
+depends=('python'
+ 'python-marshmallow'
+ 'python-requests')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('0d14675e32a6d148c87bc997431078872ee477a8e84df5b2bfd592e5467ce37b')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}