summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMubashshir2021-09-03 21:22:26 +0600
committerMubashshir2021-09-03 21:22:26 +0600
commitf1c75fbc9ade8780bd4a8479f259f1ae8975fc05 (patch)
treeb4c37207a6b0bdcd86710434329baf20dfcb8db4 /PKGBUILD
downloadaur-f1c75fbc9ade8780bd4a8479f259f1ae8975fc05.tar.gz
Init package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57289ac29514
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mubashshir <ahmubashshir@gmail.com>
+# pkg: pypi PyGLM
+
+pkgbase='python-pyglm'
+pkgname=('python-pyglm')
+_module='PyGLM'
+pkgver='2.3.1'
+pkgrel=1
+pkgdesc="OpenGL Mathematics library for Python"
+url="https://github.com/Zuzu-Typ/PyGLM"
+depends=('python')
+makedepends=('python-setuptools')
+license=('ZLIB')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('f12097dfcb709b22e31122a0e579a6ebc50f0822569ee05ac55f5347a36ee13f')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}