summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorotreblan2019-11-19 18:43:46 -0500
committerotreblan2019-11-19 18:43:46 -0500
commit3c3a62ba2ae94bb5789b8fe043f53b6f4e580b7d (patch)
treecdbd8df6361465b42b8f595a65ca92498c639585 /PKGBUILD
downloadaur-3c3a62ba2ae94bb5789b8fe043f53b6f4e580b7d.tar.gz
Generic language server
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56cc73676c61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Otreblan <otreblain@gmail.com>
+
+pkgname=python-pygls
+_name=${pkgname#python-}
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="Pythonic generic implementation of the Language Server Protocol"
+arch=('any')
+url="https://github.com/openlawlibrary/pygls"
+license=('APACHE')
+groups=()
+depends=("bandit" "flake8")
+makedepends=("python-sphinx" "python-sphinx_rtd_theme" "python-setuptools")
+checkdepends=("python-mock" "python-pytest" "python-pytest-asyncio")
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+noextract=()
+sha256sums=("780fd0c5ae95ad02ecaf70b071e43ff8ced8384b7d6bed19311a7b431d26fb88")
+
+build() {
+ cd "$_name-$pkgver"
+
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}