summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2020-03-14 09:56:12 -0400
committeracxz2020-03-14 09:56:12 -0400
commitd2e2ca96bd49102418fc279164c15fe4b8e73b5b (patch)
tree51186d5b39b9563cc0048f4ec44e833cf2c37d8b /PKGBUILD
parenta50e4300a8521e455736756859f377967f109248 (diff)
downloadaur-d2e2ca96bd49102418fc279164c15fe4b8e73b5b.tar.gz
updpkg: 2.14.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 739a78ee42f0..6c498f93734a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=python-pygmo
-pkgver=2.13.0
+pkgver=2.14.0
pkgrel=1
pkgdesc="Perform parallel computations of optimisation tasks (global and local) via the asynchronous generalized island model (Python version)"
arch=('i686' 'x86_64')
-url="https://esa.github.io/pagmo2/index.html"
+url="https://esa.github.io/pygmo2/"
license=('GPLv3')
depends=('python' 'boost' 'pagmo' 'python-numpy' 'python-cloudpickle')
-optdepends=()
-makedepends=('cmake')
-_name=pagmo2
+optdepends=('python-matplotlib' 'python-dill')
+makedepends=('cmake' 'python' 'pybind11' 'pagmo' 'boost')
+_name=pygmo2
source=(https://github.com/esa/${_name}/archive/v${pkgver}.tar.gz)
-sha512sums=('c33069abd513454777a9cc8df24437c7feba2ec64c20b0b123e9cf92cb9877553cd67b1b55c9252d65a1d9ee204492911c3b17a32140a2176694c694f27d9287')
+sha256sums=('72000a0c6bd22b8955a65ebfcb53a8f42e8b00fd16afc0b7b43ef74b14883d60')
_buildtype="Release"
@@ -29,8 +29,6 @@ build() {
cmake \
-DCMAKE_BUILD_TYPE="${buildtype}" \
-DCMAKE_INSTALL_PREFIX="/usr" \
- -DPAGMO_BUILD_PAGMO=OFF \
- -DPAGMO_BUILD_PYGMO=ON \
"${srcdir}/${_name}-${pkgver}"
msg "Building the project"