summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsean09212019-04-23 05:35:41 +0000
committersean09212019-04-23 05:35:41 +0000
commitcb3028a302716e5294eb47950003368c4e5af9aa (patch)
tree5f02b9accc9a1d687ca351d23260cfbc79739b57 /PKGBUILD
parent4ff574dcabe8fb5549d139431866c0ee2ad1bf34 (diff)
downloadaur-cb3028a302716e5294eb47950003368c4e5af9aa.tar.gz
change pygmt version to git version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8845bc7ace71..a740ae9bc179 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,9 @@
_pkg=pygmt
pkgbase=python-${_pkg,,}
pkgname=("python-${_pkg,,}")
-pkgver=0.0.1a0
-pkgrel=2
+pkghashver=f42da4382629015c568612f045f749fc2c6bd1a1
+pkgver=0.0.1a0_${pkghashver}
+pkgrel=1
pkgdesc="Python interface to the Generic Mapping Tools C library"
arch=('x86_64')
url="https://www.pygmt.org"
@@ -14,22 +15,22 @@ makedepends=('cython' 'python-setuptools' 'python-numpy' 'python-pandas' 'python
#makedepends=('cython' 'python-setuptools' 'python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt>=6.0.0' 'gmt-coast' 'gmt-dcw'
# 'ipython' 'python-matplotlib' 'jupyter' 'python-pytest' 'python-pytest-cov' 'python-pytest-mpl' 'python-coverage' 'python-black' 'python-pylint' 'flake8' 'python-sphinx'
# 'python-sphinx_rtd_theme' 'python-sphinx-gallery' 'python-nbsphinx' 'python-numpydoc')
-source=("https://files.pythonhosted.org/packages/77/72/5dfc13ff2be531366a735047892f8c99d709f1289c1eb5f4d0f656b35ce6/pygmt-${pkgver}.tar.gz")
-sha256sums=('0bba865dea5cedcbac52ece31775ddf9b1c2bf1629e585cd6bc1fce848b09add')
+source=("https://github.com/GenericMappingTools/${_pkg,,}/archive/${pkghashver}.tar.gz")
+sha256sums=('d2acb07c2d3ab5eb2ed16de99101057c45196c9d208e91884c8d5f42d2d10972')
build() {
- cd ${_pkg}-${pkgver}
+ cd ${_pkg}-${pkghashver}
USE_NCCONFIG=1 python setup.py build
}
#check() {
-# cd ${_pkg}-${pkgver}
+# cd ${_pkg}-${pkghashver}
# PYTHONPATH="../../build/lib" python -c 'import pygmt;pygmt.test()'
#}
package() {
depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt>=6.0.0' 'gmt-coast' 'gmt-dcw')
- cd ${_pkg}-${pkgver}
+ cd ${_pkg}-${pkghashver}
USE_NCCONFIG=1 python setup.py install --prefix=/usr --root="${pkgdir}" --skip-build --optimize=2
}