summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsean09212019-04-23 04:04:41 +0000
committersean09212019-04-23 04:04:41 +0000
commite4b200077fb5667638ed1a85df491ae346d8b908 (patch)
treeab11eb3a0a3bfdb4233139d4ffcf84dd443b7ae7 /PKGBUILD
parentf17b27f7c113c43fdb1ef5df3823fb562503ac73 (diff)
downloadaur-e4b200077fb5667638ed1a85df491ae346d8b908.tar.gz
add development tool for make depends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d157972e29c3..fd3e4afc7af1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,9 @@ arch=('x86_64')
url="https://www.pygmt.org"
license=('3-BSD')
#numpy, pandas, xarray, netCDF4, packaging
-makedepends=('cython' 'python-setuptools' 'python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt>=6.0.0')
+makedepends=('cython' 'python-setuptools' 'python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt>=6.0.0'
+ 'ipython' 'python-matplotlib' 'jupyter' 'python-pytest' 'python-pytest-cov' 'python-pytest-mpl' 'python-coverage' 'python-black' 'python-pylint' 'flake8' 'python-sphinx'
+ 'python-sphinx_rtd_theme' 'python-sphinx-gallery' 'python-nbsphinx' 'python-numpydoc')
source=("https://files.pythonhosted.org/packages/77/72/5dfc13ff2be531366a735047892f8c99d709f1289c1eb5f4d0f656b35ce6/pygmt-${pkgver}.tar.gz")
sha256sums=('0bba865dea5cedcbac52ece31775ddf9b1c2bf1629e585cd6bc1fce848b09add')