summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordian Edenhofer2019-09-10 21:10:21 +0200
committerGordian Edenhofer2019-09-10 21:10:21 +0200
commitafaf9b666e20d8455e37b557603f6d2e2eafe85f (patch)
tree3b395819838eb259188c2a596772ae299a76c893 /PKGBUILD
downloadaur-afaf9b666e20d8455e37b557603f6d2e2eafe85f.tar.gz
addpkg: python-pyhealpix 0.0.0b2f4d51488d-1
Rename package to contain lower-case letter only.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..419e20d4a03b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Gordian Edenhofer <gordian.edenhofer@gmail.com>
+
+pkgname=python-pyhealpix
+_pkgname='pyHealpix'
+_pkgver=0.0.0
+# Unfortunately, upstream does not tag releases; just use the latest commit for now as done in the instruction material
+_commit='2f4d51488db0f6bbe9e9d30c05dd33cdb169f0f7'
+pkgver="${_pkgver}b${_commit:0:10}"
+pkgrel=1
+pkgdesc="Minimalistic Python interface for Healpix C++"
+arch=('any')
+license=('GPL2')
+url="https://gitlab.mpcdf.mpg.de/ift/${_pkgname}"
+depends=('python' 'python-numpy' 'pybind11')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://gitlab.mpcdf.mpg.de/ift/${_pkgname}/-/archive/${_commit}/${_pkgname}-${_commit}.tar.gz")
+sha512sums=('e3beaab5514fbf240d8641ad23055e369ad969b8d05163e1ac21dc997da342dec5cf0d1b2decf960358b494a783d3fe6aaf7ee2376157b20cdc5deb12a3fb47b')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${_commit}"
+ python setup.py clean
+ rm -rf build dist
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${_commit}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}