summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2022-09-06 09:49:45 +0200
committerPhilipp A2022-09-06 09:49:45 +0200
commit68066253b753e73e4076b4ccead6dcc0dc713f24 (patch)
tree3c8e0da2b837f0633df9d601aaf327c2e1fb6242 /PKGBUILD
parent9d699eb2d4c6263c6ad1e0c876a9a2461634390c (diff)
downloadaur-68066253b753e73e4076b4ccead6dcc0dc713f24.tar.gz
v1.4.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 7 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 688c24248fcd..502f98cf3faa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,23 @@
_name=pyjnius
pkgname=python-$_name
-pkgver=1.4.1
+pkgver=1.4.2
pkgrel=1
pkgdesc='Python module to access Java class as Python class, using JNI.'
arch=(any)
url="https://github.com/kivy/$_name"
license=(MIT)
depends=(python java-environment python-six)
-makedepends=(cython python-setuptools)
+makedepends=(cython python-setuptools python-installer python-build)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('8bc1a1b06fb11df8dd8b8d56f5ecceab614d4ba70cf559c64ae2f146423d53ce')
+sha256sums=('fc0637cda4ae128ec4a96ac327d352e87ea866764b01d962672870be539a9dae')
build() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py build_ext --inplace -f
- python setup.py build
-}
-
-
-check() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py test
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir" --skip-build
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE.rst"
}