summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2017-04-06 09:44:05 +0200
committerPhilipp A2017-04-06 09:44:05 +0200
commit696fcfa71d3ef1280d160b4a796635812ded9783 (patch)
treefce6a2d597b7bc84d121442fe917a719018392e0 /PKGBUILD
downloadaur-696fcfa71d3ef1280d160b4a796635812ded9783.tar.gz
v1.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..884fdfd2a13c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+_name=pyjnius
+pkgname=python-pyjnius
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='Python module to access Java class as Python class, using JNI.'
+arch=(any)
+url="https://github.com/kivy/$_name"
+license=(LGPL3)
+depends=(java-environment python)
+makedepends=(cython)
+source=("$_name-$pkgver.tar.gz::https://github.com/kivy/$_name/tarball/$pkgver")
+md5sums=(2d457e4761b27e6760cf54efb6201f17)
+
+build() {
+ cd "kivy-$_name-"*
+
+ python setup.py build_ext --inplace -f
+ python setup.py build
+}
+
+package() {
+ export PYTHONPATH="$pkgdir/usr/lib/$(readlink /usr/bin/python3)/site-packages"
+ mkdir -p "$PYTHONPATH"
+
+ cd "$srcdir/kivy-$_name-"*
+ python setup.py install --prefix="$pkgdir/usr" --optimize=1
+}