summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAustin Lund2021-09-25 12:28:08 +1000
committerAsger Hautop Drewsen2021-09-28 17:52:51 +0200
commite632ba2e89509f652e6be21e27cc09e70c5e316d (patch)
tree0ad70cac5632ac7c4a4b3091338fd4d870b50019 /PKGBUILD
parent6008aff129ba4b0b3be74c93e4bcab5201d8832b (diff)
downloadaur-e632ba2e89509f652e6be21e27cc09e70c5e316d.tar.gz
Update version to 2.10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 17 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 275d282d7f76..f6ded917620c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,29 @@
# PKGBUILD generated by pipman
# Python package author: Philippe Faist <philippe.faist@bluewin.ch>
pkgname=python-pylatexenc
-pkgver=1.3
+pkgver=2.10
pkgrel=1
pkgdesc="Python library for encoding unicode to latex and for parsing LaTeX to generate unicode text"
arch=(any)
url="https://github.com/phfaist/pylatexenc"
license=(MIT)
-makedepends=("python" "python-pip")
+depends=(python)
+makedepends=(python-setuptools)
+source=("${pkgname}-v${pkgver}.tar.gz::https://github.com/phfaist/pylatexenc/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=(bcb859affea00b5acb25aec780620170ab9d385c8f7dc266b7237ce9f47a59fd)
+
build() {
- pip install --no-deps --target="pylatexenc" pylatexenc
+ cd "pylatexenc-${pkgver}"
+ python setup.py build
}
+
package() {
- sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
- mkdir -p $pkgdir/"$sitepackages"
- cp -r $srcdir/pylatexenc/* $pkgdir/"$sitepackages"
+ cd "pylatexenc-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE.txt
+}
+
+check() {
+ cd "pylatexenc-${pkgver}"
+ python -m unittest test/test_*.py
}