summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorneodarz2020-05-21 16:12:12 +0200
committerneodarz2020-05-21 16:12:12 +0200
commit4176c2947b775ec5cbce85478e9819363fa82c44 (patch)
tree6310a30315a2b6ee847aa63e8b8141cfa484a14d /PKGBUILD
downloadaur-4176c2947b775ec5cbce85478e9819363fa82c44.tar.gz
Inital commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58421bc3f0fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: neodarz <neodarz at neodarz dot net>
+
+pkgname=python-pylibscrypt
+_pkgname=pylibscrypt
+
+pkgver=1.8.0
+pkgrel=1
+pkgdesc="scrypt for python"
+
+url='https://github.com/jvarho/pylibscrypt'
+arch=('any')
+license=('ISC')
+
+depends=('python')
+
+source=("https://github.com/jvarho/$_pkgname/archive/v$pkgver.tar.gz")
+sha512sums=('a229e92bd3e84407bfbaf6f815ce43dde0d24a3c4b57b34193c48671d8326749aa68ee82c359c78d29d49be65021763229df53583c6fccf0bae6cc6d0814cb4e')
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}