summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederic Van Assche2017-01-25 11:21:06 +0100
committerFrederic Van Assche2017-01-25 11:21:06 +0100
commit26e6380b581a6a8c3087137dabd251b2ec6f944c (patch)
treed95942bd97886e1eeef669a1665dd7171164f76a /PKGBUILD
downloadaur-26e6380b581a6a8c3087137dabd251b2ec6f944c.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aec452b7b5fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Frederic Van Assche <frederic at fredericva.com>
+pkgname=python-pylibtiff-git
+pkgver=r125.e56519a
+pkgrel=1
+pkgdesc="A python wrapper of the C libtiff library"
+arch=('any')
+url="https://github.com/pearu/pylibtiff"
+license=('custom')
+depends=('python-numpy' 'libtiff')
+makedepends=('python-setuptools' 'git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+https://github.com/pearu/pylibtiff.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $srcdir/pylibtiff
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/pylibtiff
+ python setup.py install --root="$pkgdir" --optimize=1
+}