summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSven-Hendrik Haase2016-06-28 02:23:50 +0200
committerSven-Hendrik Haase2016-06-28 02:23:50 +0200
commitad0d6c086597a633ce9d83963e4ef021da7823df (patch)
tree9c1af7feefd523546b7e1868d675c0194295fee5 /PKGBUILD
downloadaur-ad0d6c086597a633ce9d83963e4ef021da7823df.tar.gz
Push pylint-celery
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0978f33f40a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+_pkgname=pylint-celery
+pkgname=python-pylint-celery
+pkgver=0.3
+pkgrel=1
+pkgdesc="pylint plugin for analyzing celery"
+arch=('any')
+url="https://github.com/landscapeio/pylint-celery"
+license=('GPL2')
+depends=('python')
+makedepends=('python-setuptools')
+# Temp source override because there's not tag for 0.3
+source=(https://github.com/landscapeio/pylint-celery/archive/d688f97c7da6ea729d7a632db28bb37fc4aadf94.tar.gz)
+md5sums=('26051966e31fb9e8f4c127f935e424df')
+
+build() {
+ cd "${_pkgname}-"*
+
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-"*
+
+ python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
+ install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+}
+# vim:set ts=2 sw=2 et: