summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSven-Hendrik Haase2016-06-28 02:11:12 +0200
committerSven-Hendrik Haase2016-06-28 02:11:12 +0200
commit9714146583a5d84046c5e221447304d901c4fc16 (patch)
tree66c539368b33b117bf23afdbf11a93338909aec5 /PKGBUILD
downloadaur-9714146583a5d84046c5e221447304d901c4fc16.tar.gz
Push pylint-flask
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c478540d7dfc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+_pkgname=pylint-flask
+pkgname=python-pylint-flask
+pkgver=0.3
+pkgrel=1
+pkgdesc="A Pylint plugin to analyze Flask applications"
+arch=('any')
+url="https://github.com/jschaf/pylint-flask"
+license=('GPL2')
+depends=('python')
+makedepends=('python-setuptools')
+source=(https://github.com/jschaf/pylint-flask/archive/v${pkgver}.tar.gz)
+md5sums=('ddc7bde244e7cdfdb2326d2c87a96d73')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+
+ sed -i "s/0.2/0.3/" setup.py
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+
+ python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
+ install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+}
+# vim:set ts=2 sw=2 et: