summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Aranguren2020-02-18 20:01:15 +1100
committerLuis Aranguren2020-02-18 20:01:15 +1100
commita1fd35b04f427dd9a5abf7cb365f2fbc21b2d9da (patch)
treefe7f960d71a5ee8e3d2c7874fbe63f8d384088fe /PKGBUILD
parent8bb8b8f5cc19dadcb262dd7bc4216fefe6422aee (diff)
downloadaur-a1fd35b04f427dd9a5abf7cb365f2fbc21b2d9da.tar.gz
[1.2.0-1] update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7fd382e1e145..f5b619e6a075 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=python-pylru
pkgname=('python-pylru' 'python2-pylru')
_name=pylru
-pkgver=1.1.0
+pkgver=1.2.0
pkgrel=1
pkgdesc="A least recently used (LRU) cache implementation"
arch=('any')
@@ -12,8 +12,8 @@ url="https://github.com/jlhutch/pylru"
license=('GPL2')
makedepends=('python-setuptools' 'python2-setuptools')
options=(!emptydirs)
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('e03a3d354eb8fdfa11638698e8a1f06cd3b3a214ebc0a120c603a79290d9ebec')
+source=("${_name}-${pkgver}.tar.gz::https://github.com/jlhutch/pylru/archive/v${pkgver}.tar.gz")
+sha256sums=('c4dcf175f6317539199434db13ffea0f642a52fac1e547e2e5f0866686fc9292')
prepare() {
cp -a ${_name}-${pkgver}{,-python2}
@@ -29,7 +29,6 @@ build() {
package_python-pylru() {
depends=('python')
- makedepends=('python-setuptools')
cd "${srcdir}/${_name}-${pkgver}"
python setup.py install --root="${pkgdir}" --skip-build --optimize=1
@@ -37,7 +36,6 @@ package_python-pylru() {
package_python2-pylru() {
depends=('python2')
- makedepends=('python2-setuptools')
cd "${srcdir}/${_name}-${pkgver}-python2"
python2 setup.py install --root="${pkgdir}" --skip-build --optimize=1