summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRoshless2021-06-13 01:08:39 +0200
committerRoshless2021-06-13 01:08:39 +0200
commit4188c5a9c48b10772f3f7720e811f035b2eab063 (patch)
tree88d4e83e067d5b91a6b5dcfc1594217694344ce7 /PKGBUILD
parent157ec6ddb4348092274b972d4526712d8054416d (diff)
downloadaur-4188c5a9c48b10772f3f7720e811f035b2eab063.tar.gz
upgpkg: python-pyls-isort 0.2.2-2
add license file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69685eb7b825..184ea641f979 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-pyls-isort
_name=${pkgname#python-}
pkgver=0.2.2
-pkgrel=1
+pkgrel=2
pkgdesc='Isort plugin for python-language-server'
url='https://github.com/paradoxxxzero/pyls-isort'
arch=('any')
@@ -13,13 +13,15 @@ makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
build() {
- cd $_name-$pkgver
- python setup.py build
+ cd $_name-$pkgver
+ python setup.py build
}
package() {
- cd $_name-$pkgver
- python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ cd $_name-$pkgver
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
}
md5sums=('9861494cb118c309b06709b2aa1361e7')