summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorŁukasz Pożarlik2019-05-21 09:56:13 +0200
committerŁukasz Pożarlik2019-05-21 09:56:13 +0200
commit4867a8b617fbfcfc12f0997947b500c94cb789ce (patch)
tree6d18bdce2a75b3e47b713f4a4af1f403850dc9b3 /PKGBUILD
downloadaur-4867a8b617fbfcfc12f0997947b500c94cb789ce.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc0baf2812ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Lukasz Pozarlik <lpozarlik@gmail.com>
+
+_name="pyluach"
+_module="$_name"
+
+pkgname=("python-$_module" "python2-$_module")
+pkgdesc="Pyluach is a Python package for manipulating Hebrew dates, Gregorian-Hebrew calendar conversions, and other Jewish calendar related calculations"
+pkgver="1.0.1"
+pkgrel=1
+url="https://github.com/simlist/pyluach"
+license=('MIT')
+arch=('any')
+makedepends=("python-pbr>=1.9" "python2-pbr>=1.9")
+source=("https://files.pythonhosted.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz"
+"LICENSE")
+sha256sums=('4d4ad7a680390d5fe29bf5191939b801fd1b72a85f5c6713038160a265af62f7'
+ 'a6900a379815872f27df1aac58d8c249ddd085259f6bab6768e162cc82d346b1')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+ python2 setup.py build
+}
+
+package_python-pyluach(){
+ cd "$_name-$pkgver"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" ../LICENSE
+}
+
+package_python2-pyluach(){
+ cd "$_name-$pkgver"
+ python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" ../LICENSE
+}