summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexey Andreyev2020-02-01 14:40:50 +0300
committerAlexey Andreyev2020-02-01 14:40:50 +0300
commit3fff73fa4bd21057a7696e4f66e26585218ed54d (patch)
tree7e5586f177c0362491b08d17af4c83a6c363113d /PKGBUILD
downloadaur-3fff73fa4bd21057a7696e4f66e26585218ed54d.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6176651202e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Initial commit: Alexey Andreyev aa13q at ya.ru
+
+pkgbase='python-pymantic'
+pkgname=('python-pymantic')
+_module='pymantic'
+pkgver='0.2.5'
+pkgrel=1
+pkgdesc="Semantic Web and RDF library for Python"
+url="https://github.com/norcalrdf/pymantic/"
+depends=('python' 'python-requests' 'python-lxml' 'python-pytz' 'python-rdflib' 'python-lark-parser' 'python-pyld' 'python-lepl')
+makedepends=('python-setuptools')
+license=('BSD')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('119361a60d811aea6f57faf05f9aebc787e37244e3c8e9c922e9621b2a425dcf')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}