summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcell Meszaros2022-07-11 18:22:20 +0200
committerMarcell Meszaros2022-07-11 18:22:20 +0200
commitf4207fdd2fc69f3d715d6510110d8645029f5dde (patch)
tree3804ac65e9e38ed313369267adb9a9c7be4316a5 /PKGBUILD
parent3fff73fa4bd21057a7696e4f66e26585218ed54d (diff)
downloadaur-f4207fdd2fc69f3d715d6510110d8645029f5dde.tar.gz
0.2.5-2: remove unneeded python-lepl dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 19 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6176651202e..ac82bf2d722c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,29 @@
-# Initial commit: Alexey Andreyev aa13q at ya.ru
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: Alexey Andreyev aa13q at ya.ru
-pkgbase='python-pymantic'
-pkgname=('python-pymantic')
-_module='pymantic'
-pkgver='0.2.5'
-pkgrel=1
+pkgname='python-pymantic'
+_module="${pkgname#python-}"
+pkgver=0.2.5
+pkgrel=2
pkgdesc="Semantic Web and RDF library for Python"
-url="https://github.com/norcalrdf/pymantic/"
-depends=('python' 'python-requests' 'python-lxml' 'python-pytz' 'python-rdflib' 'python-lark-parser' 'python-pyld' 'python-lepl')
-makedepends=('python-setuptools')
-license=('BSD')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('119361a60d811aea6f57faf05f9aebc787e37244e3c8e9c922e9621b2a425dcf')
+url="https://pypi.org/project/${_module}/${pkgver}"
+license=('BSD')
+depends=('python' 'python-requests' 'python-lxml' 'python-pytz' 'python-rdflib' 'python-lark-parser' 'python-pyld')
+makedepends=('python-setuptools')
+_sourcename="${_module}-${pkgver}"
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/${_module}/${_sourcename}.tar.gz"
+ "${_sourcename}-LICENSE::https://github.com/norcalrdf/${_module}/raw/${pkgver}/LICENSE")
+sha256sums=('119361a60d811aea6f57faf05f9aebc787e37244e3c8e9c922e9621b2a425dcf'
+ 'c5a804cb694b36e4604f1edaf496ad7aaa93690d27666a6a7887354ec3a1a884')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py build
+ cd "${_sourcename}"
+ python setup.py build --executable='/usr/bin/env python'
}
package() {
- depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_sourcename}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install --verbose -Dm 644 "../${_sourcename}-LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}