summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShadowKyogre2016-07-12 17:49:49 -0700
committerShadowKyogre2016-07-12 17:49:49 -0700
commit228656cd3e2538308ffbfc5b4716f8bdf40ffcdd (patch)
treee0bf77d9ffe1ef238dbda86db61da21642a77f48 /PKGBUILD
downloadaur-python-pyment-git.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b366314c288a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Sapphira Armageddos <shadowkyogre.public@gmail.com>
+
+_upstream=pyment
+pkgname=python-pyment-git
+pkgver=0.3.0.r27.ga70de37
+pkgrel=1
+pkgdesc="Create, update or convert docstrings in existing Python files, managing several styles."
+arch=(any)
+url="https://github.com/dadadel/${_upstream}"
+license=(GPL)
+depends=(python)
+provides=('python-pyment')
+conflicts=('python-pyment')
+makedepends=(python-setuptools)
+source=("git+https://github.com/dadadel/${_upstream}/")
+
+pkgver() {
+ cd "${srcdir}/${_upstream}"
+ git describe --long --tags|sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package () {
+ cd "${srcdir}/${_upstream}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+
+}
+
+sha256sums=('SKIP')