summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXiretza2021-07-12 11:59:31 +0200
committerXiretza2021-07-12 11:59:31 +0200
commit5b7712f7e310d64cee7600b5d48a70ab169305c7 (patch)
treee9a7e31c93fbea8d194250aec6828e0adb50ea04 /PKGBUILD
downloadaur-5b7712f7e310d64cee7600b5d48a70ab169305c7.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac6ff8970c15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: xiretza <xiretza+aur@xiretza.xyz>
+
+_pkgname='pyMetaClasses'
+pkgname=python-${_pkgname,,}
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="A collection of MetaClasses for Python"
+arch=(any)
+url="https://github.com/Paebbels/pyMetaClasses"
+license=('Apache')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('34644093c43858b95fdae79f6d5611aa3fb28bb745ef1fef26feaf7ef71db61f')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+check(){
+ cd "$_pkgname-$pkgver"
+ #pytest
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}