summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAllen Li2015-06-09 02:05:03 -0700
committerAllen Li2015-06-09 02:05:03 -0700
commit686d61897dc49a13e0efdcb6f245ea9b9364b6d9 (patch)
tree7c100f1f7a63e082f3e7e29027d46b21bd52bf9b /PKGBUILD
downloadaur-686d61897dc49a13e0efdcb6f245ea9b9364b6d9.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7506d5b6a98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Allen Li <darkfeline@abagofapples.com>
+pkgname=python-pymysql-git
+pkgver=20130105
+pkgrel=1
+pkgdesc="Pure Python MySQL Client"
+arch=(any)
+url="https://github.com/petehunt/PyMySQL"
+license=('GPL')
+license=('BSD')
+depends=('python')
+makedepends=('git' 'python-distribute')
+conflicts=('pymysql')
+
+_gitroot="https://github.com/petehunt/PyMySQL"
+_gitname=pymysql
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ ./build-py3k.sh
+ cd py3k
+ python setup.py install --root="$pkgdir" --prefix=/usr
+ install -Dm0644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: