summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFilippo Berto2020-08-10 10:22:49 +0200
committerFilippo Berto2020-08-10 10:22:49 +0200
commitd56f9c265d927a41d29cb0d47095fa0017eafca2 (patch)
tree1c3eec4255ebdd78588c7f29b83897b9592c3533 /PKGBUILD
parentf868571e1edcb95b99fc659ab5b75eb34f0536b7 (diff)
downloadaur-python-pyndn.tar.gz
Explicit python3 + fix deps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a89990d1ec5..8ed4c667a52f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@ arch=('i686' 'x86_64')
url="https://github.com/named-data/${_reponame}"
#license=('GPL')
groups=()
-depends=('python' 'python-cryptography')
-makedepends=('ndn-cxx')
+depends=('python' 'python-cryptography' 'ndn-cxx')
+makedepends=()
checkdepends=()
optdepends=()
provides=("${pkgname}")
@@ -27,10 +27,10 @@ validpgpkeys=()
build() {
cd "${srcdir}/${_reponame}-${pkgver}"
- python setup.py build
+ python3 setup.py build
}
package() {
cd "${srcdir}/${_reponame}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python3 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}