summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-02-11 11:49:05 -0700
committerMark Wagie2021-02-11 11:49:05 -0700
commit85bf9b9397d692450b5c108cc5fdd14ecc140b00 (patch)
treed035f7d31ac12770238d03c9295c1aac30069c8c /PKGBUILD
parenta9cf913545082b1eb2721fa0d0dc696ba54c2b0b (diff)
downloadaur-85bf9b9397d692450b5c108cc5fdd14ecc140b00.tar.gz
fix permissions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 584a78b33f7b..c51dfae63f28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-pynput
_name=${pkgname#python-}
pkgver=1.7.3
-pkgrel=1
+pkgrel=2
pkgdesc="Python library to monitor and control user input devices"
arch=('any')
url="https://github.com/moses-palmer/pynput"
@@ -30,4 +30,8 @@ package() {
cd "$_name-$pkgver"
export PYTHONHASHSEED=0
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+
+ # Fix permissions
+ find "$pkgdir" -type d -exec chmod -v 0755 {} \;
+ find "$pkgdir" -type f -exec chmod -v 0644 {} \;
}